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1  Introduction  

1.1 Overview  

CL Studio Live is a new way to create, share and interact with visual content. With numerous 

effects, extensions and camera components CL Studio Live provides endless combinations for 

real-time visual content manipulation . Our goal is to empower visual artists to manipulate media 

with simple and powerful solutions that deliver high performance and intuitive tool s for 

capturing, filtering  and media manipulation. 

 

CL Studio Live provides a library of high performance and modern filtering techniques  and 

powerful input, output, mixing and processing extensions.  We leverage the latest Microsoft 

Technologies such as Windows 7’s real time media threading, Media Foundation, DirectShow, 

DirectCompute and DirectX 10.1.  

 

This documentation will help introduce you to the application and key components and areas of 

usage. We hope you enjoy using CL Studio Live as much as we enjoyed building it and look 

forward to the fu ture of interactive media. 
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1.2 Features 

 

¶  Real-Time Visuals 

Allows for mixing of cameras, videos and image sources. 

¶  Dynamic Cabling/Controls   

Precisely route complex video paths with an intuitive  visual editor. 

¶  Highly Extendable   

With a growing  library of modules, and over 45 modules available now. 

¶  Optimized for Performance   

Built on the latest DirectX 10.1 GPU architecture. 

¶  Visual Projects Editor  

Save, load and share your works with a standard file format. 

¶  Web Streaming   

Web one-to-many live broadcasting to quickly publish media. 

¶  Getting Started Examples   

With numerous samples and video tutorials to help get started. 

¶  MIDI Hardware  Support   

Allows for users to control  module parameters with standard MIDI devices. 

 

1.3 Usage Scenarios 

¶  Computer Vision   

Optimized for human sensing offering  a range of filtering  and blending. 

¶  Live Performances   

Adjustable controls and outputs, perfect for any life performer. 

¶  Video Compositing   

Allows mixing of unlimited  simultaneous signal sources. 
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1.4 Requirements  

Hardware Syste m Requirements  

 

¶ Intel Core Duo 2.0+ GHz CPU (Intel i7 or comparable recommended) 

¶ ATI or NVIDIA GPU with Pixel Shader Model 4.0+ and DirectX 10.1 support  

¶ 512 MB+ Graphics Memory 

¶ 1024 MB+ System Memory 

¶ 500 MB Available Disk Space 

¶ Internet Connection for Product Activation  

¶ Windows Experience Index Rating of 5.0+  

 

Software System Requirements  

 

¶ Microsoft Vista/Windows 7 Operating System 

¶ Microsoft .NET 4.0 Redistributable  * 

¶ Microsoft Visual Studio 2010 Redistributable  * 

¶ Apple Quicktime 7+  

¶ Adobe Flash Player 9+ 

¶ Modern Web Browser (Google Chrome, Safari, Firefox, IE 7+, etc…) 

¶ CL Eye Platform Driver  (Use for PS3 Eye Camera Support)  

¶ Microsoft DirectX  (June 2010 Release or Newer)  * 

 

Note:   Items noted with  a * are included with the installer. 
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2 Installing  &  Acti vat ion  

Installing consists of following steps 

 

1) Get the latest CL Studio Live Installer at: http://codelaboratories.com/get/studio/  

2) Acquire Software Key (Trial or Purchased) See: 2.2 

3) Activate CL Studio Live with a valid License Key 

 

2.1 Installation  

 

 

 

 

Note:      You must agree to the license to install and use CL Studio Live. 

http://codelaboratories.com/get/studio/
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2.2 Acquiring  License Keys 

There are currently  three  types of licenses available  for CL Studio : 

 

¶ Trial -  Lite  -  Live 

¶ You can acquire a key from: http://codelaboratories.com/studio/  

¶ CL Studio Live License: http://codelaboratories.com/kb/CL -Studio-Live-License/ 

¶ See reference 8.9 for Licensing Comparison 

¶ To get a Trial Key you must create CL Account and View your My Licenses page. 

 

Note:   A valid CL Membership is required to obtain product keys.  

2.3  Activation  the Software  

To activate simply paste the key you received in the above step, after this your key will be 

verified and CL Studio Live will be ready to use.  

 

 

Your activation is complete once you receive a  next to the input field . 

http://codelaboratories.com/studio/
http://codelaboratories.com/kb/CL-Studio-Live-License/
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3 Getting Started 

3.1  Application Overview  

 

Application Components 

¶ Rack Editor  

¶ Modules (Effects/Extensions)  

¶ Cabling/Ports 

¶ Media (Images/Videos/Textures) 

¶ Proxies (DirectShow Filters) 

 

Application Views 

¶ Rack Front & Back  

¶ Main Menu 

¶ Module Context Menu  

¶ Rack Context Menu -  

¶ Settings Window – Application personalization and setup. 

¶ Load File Window – Used for loading file or URL assets. 

 

Hardware Components  

¶ Input Devices (CL Eye Supported Devices) 

¶ Output Devices (Monitors/ Projectors) 
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3.2 Creating a New Project  

Creating a new project is simple; just select File > New  and a new rack will be generated. Make 

sure you save your previous work as this does create a new empty rack. 

3.3 Saving and Loading  Projects  

To save your projects choose the File > Save command from the Main Menu, Also keyboard 

shortcuts (Ctrl+S, Ctrl+Shft+S)  are available to quickly save your files. Once a file is saved it can 

be opened for editing by using the Open or Open Last commands from the menu or keyboard 

(Ctrl+O , Ctrl+L ). 

 

 

 

Main Menu with File Menu Shown - See Reference 8.1 + 8.2 for menu shortcuts. 

Note:   Projects are saved with the *.RACK file extension. 
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3.4 Adding Modules  

With modules users can construct desired video transformations and filtering  and much more. 

To add a module you can Right Click  anywhere on the Rack space or select a group for the Main 

Menu, this will show your active Module Library .  

 

 

 

Rack Context Menu Shown – Lists available modules See: Reference 8.3 

 

CL Studio Live is built around a “virtual hardware” concept so users can interact with   

Effect &  Extension Modules that are loaded into The Rack Editor  like shown below. 
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4 Components  

4.1 Modules (Effects & Extensions)  

Each module consists of 5 base elements  

 

1. Power Buttons (Module Bypass)  

2. Controls (Visual Interface of Parameters)  

3. Parameters (Mapped to Controls underlying numerical values) 

4. Ports (Used with cables to connect with other rack modules)  

5. Visual Skins (Colors & Themes) 

 

Module s are separated into two groups  

 

¶ Effect s – Manipulate signals based on parameter set. (Reference 8.3) 

¶ Extensions  – Act as signal generators, mixers and input/output . (Reference 8.4) 

 

Below are some example modules one from each group:  

 

 

Example Effect ð The Blend Module allows for blending of two visual color modes.  

 

 

Example Extension ð The 6 Port Mixer Module allows for mixing of several signals. 

 



 

CL Studio Live  

CL Studio Live  Docs        Code Laboratories -  Copyright 2010                           Page 13  of 36     

 

4.2 Rack Editor  

The Rack Editor is the main application in which you can manage all modules and their position 

in the visual graph editor pipeline. Here are some quick tips for getting started with the editor.  

 

 

 

¶ Change the Module Colors  by hitting the C Key while viewing the back of the editor. 

¶ Toggle the Main Menu by hitting the Spacebar you can minimize the main menu. 

¶ Left Click  anywhere on Rack to Drag or use Up/Down Scroll Wheel . (Smooth Scrolling) 

¶ Right Click  anywhere on Rack to Show the Main Context Menu to Add Modules . 

Note:   You can quickly toggle in between the front and back view with the TAB Key. 
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4.3  Cabling & Ports  

 

 

Cabling in CL Studio emulates a real world environment  with each module having a number of 

I/O ports that can be connected to each other. This allows for a module to act as a source for 

multiple target modules as well as allows for complex daisy chaining  of effects and extensions. 

Note:   A simplified graph equation with modules would look li ke:  Media > Transform > Display   

 

 

This cabling metaphor brings the ability t o interconnect modules in a wide range of 

combinations to manage complex signal flows. When cabling, users create a filter graph which 

allows for very dynamic results. To reset modules connections use View >  Clear Cables menu 

item from  the Main Menu. 

Note:   When successfully connected, ports will highlight and t he cable will turn solid yellow. 
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4.4 Cameras 

CL Studio is capable of supporting up to 16 simultaneous camera devices. The Camera Module  

allows for management of individual cameras in your project, it also has controls for adjustment 

of exposure and gain as well as provides a thumbnail preview of the current video from camera 

devices. The Camera Module  can be loaded from Extensions > Input  > Camera 

To use cameras in CL Studio they must be activated via the CL Eye Device Manager which is 

included in the CL Eye Driver installation. You can learn more here: 

http://codelaboratories.com/eye/  

 

 

 

 

 

Note:   You must have activated CL Eye Camera Devices to use it in the Camera Module. 

http://codelaboratories.com/eye/
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4.5 Display s 

Displays create virtual display windows which can be spread across physical displays, supporting 

both projection and flat panel technologies  and provides accurate mapping of video overlays.  

The virtual display can be toggled on/off using the power button o f their associated module. The 

Display  Module  can be loaded from Extensions > Output  > Display  

 

 

 

 

 

 

Note:   Make sure to try the Capture  button on right to quickly save images. 
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4.6 MIDI  

CL Studio supports all MIDI input devices that send standard control change  (CC) messages.  

Flexible learn  mode allows for quick MIDI control mapping to any module knob/button. 

Mapping of the physical MIDI controls to the virtual ones is as simple as double clicking on the 

module control you wan t to map and then move the slider or knob on your MIDI control device . 

The on-screen control will glow for 1 second to indicate that the learning mode is activated.  

 

 

Note:   An example of supported nanoKontrol MIDI controller from Korg’s hardware series. 

 

 

Note:   You can set your active MIDI controller from the Settings > Devices  window. 
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5 Media Import/Export  & Streaming  

CL Studio is capable of handling media in several ways: 

 

¶ Media Import  ð Media Module  - See below for supported media formats. 

¶ Image Expo rt  ð Display Module – JPG with “Capture” Button 

¶ Video Export  ð DS Proxy Module  

Á Adobe Flash Platform 

Á Microsoft .NET Framework  

Á See Reference 8.5 for Supported DirectShow Applications 

Á Full Apple Quicktime Support 

¶ Live Streams  ð DS Proxy to CL Streaming Services 

 

5.1 Supported Formats  

Image Import  

*.BMP;*.DIB;*.FPX;*.GIF;*.JPE;*.JPEG;*.JPG;*.MAC;*.PNG;*.PNTG;*.PSD;*.QIF;*.QTI;*.QTIF;*.SGI

;*.TGA;*.TIF;*.TIFF 

 

Video  Import  

*.MOV;*.3DM;*.3DMF;*.3G2;*.3GP;*.3GP2;*.3GPP;*.AMC;*.AVI;*.CEL;*.DIF;*.DV;*.FLC;*.FLI;*.G

IF;*.M3U;*.MJ2;*.MP4;*.PICS;*.PLS;*.QHT;*.QHTM;*.QTPF;*.RTSP;*.SDP;*.SDV;*.SKIN;*.SMI;*.

SMIL;*.SML;*.SWF;*.VFW;*.PLS 

 

MPEG Import  

*.M1S;*.MPEG;*.MPG;*.MPM;*.M15;*.M1V;*.M75;*.MPV;*.M2P;*.M2S;*.VOB;*.VRO;*.M2V 
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5.2 Media Import  

Media loading support comes via the Media Module . This module is capable of loading any 

supported image or video file located on the local computer or internet.  You can control several 

aspects of video playback such as “rate”, looping, horizontal and vertical flipping. 

 

 

 

The Media Module is similar to the Camera Module in that it can act as a video signal source to 

be used in your mixes. To load a file click either the Image or Video button which will show you a 

file dialog window, from this select a supported file format you want to load into your module.  

 

It is also possible to load media assets from network and web locations, to do this simply paste 

your file URL in the File Selection Dialog Window. The URL path must be valid and properly 

formatted and is limited to a maximum of 260 characters in length.  

 

Note:   Default Image and Video folder paths can be set in the Folder Settings. 
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5.3 Image Export  

Each Display module window has a button labeled Capture  which you can use to quickly save a 

displayed image in a JPG format to your default Capt ures Folder (See reference 6 for Application 

Settings). 

5.4 Video Export   

Any application supporting Microsoft DirectShow API will support receiving video streams from 

CL Studio. This brings the ability to export video to various applications such as Adobe Flash, 

AIM, Skype, Silverlight and many more. 

 

 

 

 

 

You can use CL Eye Test Application to Save Video to AVI Format or use any of the DirectShow 

Applications noted in Reference 8.5 

Note:   CL Studio must be running first before you launch the receiving application. 
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5.5 Live Streams 

CL Studio supports live web broadcasting with the use of Adobe Flash Platform. With this we 

provide multiple real -time multicast streaming channels to all CL Studio licensed customers. You 

can launch and start streaming at any time directly from CL Studio with the File > Stream  menu 

item. (Please note Live Streams are for non-trial users only until we are out of beta)  

 

 

 

You can adjust several aspects of your Live Stream Page to personalize it: 

¶ Channel Title/Description 

¶ Background Image 

¶ Thumbnail Image 

¶ Social Links (Blog, Facebook, Twitter etc…) 

 

You can also login from any browser to begin publishing to your live stream: 

http://codelaboratories.com/studio/stream/  

http://codelaboratories.com/studio/stream/
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5.6 Sharing Live Streams 

 

 

You can view your stream by visiting: http://codelaboratories.com/live/  + your CL Username.  

 

For example: http://codelaboratories.com/live/ username  

 

Once streaming you will be able to send your URL to anyone or share it with the social toolbar 

on the bottom right. You can determine how many viewers are currently watching your channel 

by the view counter below your main video. You can also view other member’s stream channels 

by clicking on the Live link on the top left of menu bar.  

http://codelaboratories.com/live/
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6 Settings  

You can access the CL Studio settings by clicking on Settings  in the main menu. From there you 

can control several aspects of the application’s behavior, such as UI animation, keyboard 

mappings, default folders and more. 

 

The main settings are divided into the following sections:  

 

¶ General – Keyboard and Framerate 

¶ Folders  – Default Folder Paths  

¶ Visuals – Animation and Toggles  

¶ Devices – MIDI and compatible camera devices 

¶ My Studio  – Manage your Studio account and activate the product  

 

 

 

1) Keyboard Mapping  – Maps (F1-F19) Keys to modules in the rack (based on module position)  

2) Lock Mouse to Controls  – Hides mouse while interacting with controls  

3) Framerate  – Toggles between 30 and 60 frames per  second (FPS) 
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1) Captur es Folder – Default folder for Image Export (Capturing from the Display Module)  

2) Images Folder  – Default folder for Image Import (JPG, PNG etc…) 

3) Videos Folder  – Default folder for Video Import  (AVI, MOV, etc…) 

4) Projects Folder  – Default folder for Saved Rack Projects (*.RACK) 

 

 

 

1) Cable Fades – Animated fading of cables on interaction/update  

2) Cable Shadows – Drop shadows and lighting effects 

3) Smooth Scrolling  – Enable animated scrolling of rack  

4) Hide Menu  – Show/Hide Main menu with the keyboard 
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7 Help  & Support  

7.1 Loading the Examples  

CL Studio comes with several examples in order to help you get started. To load these simply 

click the Help > Examples menu item and then select the example you would like to load. 

 

 

 

 

Here are some simple graph ideas to experiment with: 

 

¶ Loading of Media (Media > Display  - Add a Media Module and Link to a Display) 

¶ Basic Capture (Camera > Display  - Add a Camera Module and Link to a Display) 

¶ Basic Effect  (Camera > Transform > Display  -  Add Camera, Transform and Display) 

¶ Basic Export Stream (Camera > DS Proxy  – Add a Camera and a DS Proxy Module, open a 

web browser and test the output stream)  
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7.2 Frequently Asked Questions (FAQ)  

You can find the latest FAQ at: http://codelaboratories.c om/studio/faq  

7.3 Community Support  

Community Support : http://codelaboratories.com/forums/ 

7.4 Commercial Support  

Commercial Support: http://codelaboratories.com/commercial-forums/ (Login Required) 

7.5 Troubleshooting  

To begin troubleshooting we included a diagnostic utility which you can launch from the Start 

Menu under CL Studio Live > Tools > CL Studio Diagnostics Utility . This tool will perform 

some simple tests and gauge the experience rating of your hardware. The produced index rating 

reflects your computers overall performance. 

 

Here are some general troubleshooting tips:  

 

Confirm that your computer meets the following minimum requirements: 

¶ A Windows Experience Rating above 5.0 

¶ DirectX 10.1 – Full Hardware Acceleration 

¶ Properly installed Quicktime 

If you are experiencing issues with the software, try and lower some of your visual settings: 

 

¶ Disable Cable Fades/Shadows and Smooth Scrolling (Settings  > Visual ) 

¶ Lower the frame rate from 60 to 30 FPS (Settings > General) 

¶ Disable Windows Aero and Theming Effects from the Windows control panel  

 

If problems persist, please try re-installing the application and post any errors you receive via the 

support contact form : http://codelaboratories.com/support/  

http://codelaboratories.com/studio/faq
http://codelaboratories.com/forums/
http://codelaboratories.com/commercial-forums/
http://codelaboratories.com/support/
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8 References 

8.1 Main Menu  

Menu Item  Description  Keyboard  

File General Application Commands (Open, Save, Publish) Alt+F 

Effects Effect Module Listing (For manipulating sign al) Alt+E 

Extensions Extension Module Listing (For signal input/output)  Alt+X 

Settings  
Application preferences and configurations (See: 

Application Settings 6) 

Alt+S 

View Toggle editor view states and clearing of cables Alt+V 

Help  Examples, product details, support and documentation  Alt+H 

8.2 Keyboard Shortcut s 

Action  Description  Keyboard  

Save Save the current project  Ctrl+S 

Save As Save the current project as a new file Ctrl+Shift+S 

New Create a new rack project Ctrl+N 

Open Open an existing project from disk Ctrl+O 

Open Last Open the most recently used project Ctrl+L 

Flip Rack Change the view of the rack Tab 

Toggle Colors  Show/Hide individual module color pickers  C 

Exit Exit the application  Alt+F4 

Module Toggle  Optional mapping of modules on/off parameter.  F1-F19 



 

CL Studio Live 

CL Studio Live  Docs        Code Laboratories  -  Copyright 2010                                     Page 28  of 36     

 

8.3 Effect s Library   

Module  Description  I/O Ports  Controls  Parameters Group  

Cubic 
Applies cubic transformations on 

signal.  

1/1 5 Scale 

Distortion  

Cubic  

Chromatic  

Invert 

2D 

Transform  
Applies linear transformations on 

signal. 

1/1 4 Pan 

Zoom 

Rotate 

Skew 

2D 

Water  
Creates waves dependent on 

motion detected in input video.  

2/1 3 Attack 

Decay 

Strength 

2D 

Flat Tunnel  
Maps input texture to 2 flat walls 

and animates forward motion. 

1/1 2 Speed 

Fade 

3D 

Light Pulse  
Applies a 3D lighting and 

distortion to input.  

1/1 1 Speed 3D 

Relief Tunnel  
Creates a round tunnel with 3D 

texture mapping  

1/1 2 Speed 

Fade 

3D 

Tunnel  Creates a round 3D tunnel. 
1/1 2 Speed 

Fade 

3D 

Z-Invert  Flips signal on Z axis. 
1/1 2 Speed 

Fade 

3D 

Light Sphere  Maps input texture to 3D sphere. 1/1 1 Speed 3D 

Blur Rotate  3D Blur transformation on X axis. 
1/1 2 Center 

Offset 

Blur 

Blur Zoom  3D Blur transformation on Z axis. 
1/1 2 Center 

Scale 

Blur 

Blend 

Apply color transformations to 

multiple signals (such as burn, 

dodge, etc.) see Reference 8.8 

2/1 3 Mode 

Gain 1 

Gain 2 

Color 

Brightness  Adjust Brightness/Contrast  
1/1 2 Brightness 

Contrast 

Color 
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Module  Description  I/O Ports  Controls  Parameters Group  

Color Tone  Changes color key of signal. 1/1 1 Color Color 

Grayscale 
Converts the image to black and 

white. 

1/1 0 - Color 

Invert  Inverts the image color. 1/1 0 - Color 

Frosted Glass Creates foggy glass-like effect. 1/1 1 Strength Distort 

Texturize  Overlaps input textures. 2/1 1 Strength Distort 

Twist  Warps the signal on polar axis. 1/1 1 Size Distort 

Wave 

Creates liquid-like distortions 

such as ripple, warp, swirls etc… 

 

Wave Modes 1-4 

1/1 4 Mode 

Amplitude  

Frequency 

Rate 

Distort 

Checkers 
Creates a checkerboard pattern 

with a controllable tile count. 

0/1 1 Count Pattern 

Circles 

Segments video signal into 2D 

circles with adjustable size and 

count. 

1/1 4 Count 

Size 

Strength 

Smooth 

Pattern 

Kaleidoscope  
Pattern replicating and 

repositioning.  

1/1 1 Speed Pattern 

Lines 
Creates linear shapes spanning 

the full width of the image. 

1/1 1 Size Pattern 

Pixelate  
Changes the individual pixel size 

of the image. 

1/1 1 Pixel Size Pattern 

Shades 
Creates linear shaded strips with 

drop shadows. 

1/1 2 Count 

Intensity 

Pattern 

Spheres 
Similar to Circles but with 3D 

shading. 

1/1 3 Size 

Strength 

Smooth 

Pattern 

Star 
Transforms input into a 5 point 

animated polygon. 

1/1 1 Speed Pattern 

Granite  Creates a rock-like textures. 1/1 1 Size Sketch 
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Module  Description  I/O Ports  Controls  Parameters Group  

Tiles 

Allows for a video signal to be 

cloned, tiled and repositioned on 

the X/Y axis. 

1/1 4 H Count 

V Count 

H Offset 

V Offset 

Pattern 

Stroke  Artistic pen/pencil effect. 1/1 1 Strength Sketch 

Contours  
Creates an outline of the signal 

dependent on the Size/Strength. 

1/1 2 Size 

Strength 

Stylize 

Edge 
Enhances the edges of the 

image. 

1/1 4 Threshold 

Sobel 1 

Sobel 2 

Soble 3 

Stylize 

Emboss 

Enhances highlight and shadow, 

depending on light/dark 

boundaries. 

1/1 2 Amount  

Width 

Stylize 

Sharpen Creates or refines sharp edges. 
1/1 2 Amount  

Width 

Stylize 

Threshold  
Cuts anything below the set limit 

of at pixel level. 

1/1 1 Threshold Stylize 

Vectorize  
Creates outline vectors based on 

color threshold adjustment.  

1/1 1 Threshold Stylize 

Bullet  
Time delay Matrix  effect of the 

visual signal. 

1/1 1 Mix Time 

Delay 
Time Delay with 1, 2, 3 and 4 

image frame delayed outputs. 

1/4 0 - Time 

Echo 

Time shift with the following 

modes: First, Last, Add, Max, Min, 

Blend, Inverse Blend. 

1/1 1 Mode Time 

SlitScan 
Time shift based on history and 

direction. 

1/1 2  Mode 

Depth 

Time 

Optical Flow  
Outputs directional vectors 

based on the motion of a scene. 

1/1 1 Gain 

 

Vision 
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8.4 Extension s Library  

Module  Description  I/O Ports  Controls  Parameters  Group  

Media  
Media import from file sources 

(See Supported Formats 5.1) 

0/1 4 File 

Playback Rate 

Loop 

Horizontal Flip 

Vertical Flip 

Input 

Display  Virtual video display window. 

4/0 6 Mix 1 

Mix 2 

Mix 3 

Mix 4 

Output  

Fractal 
A Mandelbrot or Julia fractal 

generator with zoom and pan. 

0/1 4 Mode 

Zoom 

Pan 

Generator 

Camera 

Allows for CL/PS3 Eye Camera 

devices to be used as a video 

source. 

0/1 3 Exposure 

Gain 

Input 

DS Proxy 

Allows for CL Studio to broadcast 

as a Microsoft DirectShow video 

source device (See: Supported 

Applications 8.5) 

4/0 6 Mix 1 

Mix 2 

Mix 3 

Mix 4  

Horizontal Flip 

Vertical Flip 

Output 

Mixer  
A Six Port mixing module for 

merging/managing video signals. 

6/1 6 Mix 1 

Mix 2 

Mix 3 

Mix 4 

Mix 5 

Mix 6 

Mix 
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8.5 Supported Applications  

Application  Status Version  Mode  

Adobe Flash Player  Supported 9-10+ DirectShow 

Skype  Supported 4+ DirectShow 

AIM  Supported - DirectShow 

Yahoo  Supported - DirectShow 

CL Eye Test Supported - DirectShow 

    

See: http://codelaboratories.com/eye/apps/ for supported DirectShow applications. 

 

8.6 Controls Library  

Control  Description  

Knob  Radial adjustments of values (bipolar or unipolar modes ). 

Toggle  On/Off button . 

X/Y Pad Two-dimensional adjustments along the X and Y coordinates. 

Port  Input or Output  Signal Endpoints. 

Color Picker  Red, Blue, Green Color Picker. 

Cables Visual connections between modules. 

 

 

 

http://codelaboratories.com/eye/apps/
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8.7 Terms & Definitions  

Term Description  

DirectShow  A Microsoft developed framework for multi -media management. 

GPU Graphics Processing Unit – used for rendering graphics in a modern computer.  

Rack Main application space used to manage modules. 

Module  Used within a rack to create projects.  

Media  Graphical and signal assets loaded from file s or other device sources. 

DS Proxy Virtual Camera Source Component for use with target DirectShow Applications.  

 

8.8 Blend Mode Refe rence 

Mode  Description  

Normal  
This is the standard blend mode which simply takes each pixel from the top layer if 

present. Otherwise the bottom layer is used. 

Brighten  
This blend mode simply adds pixel values of one layer with the other. In case of values 

above 255 (in the case of RGB), white is displayed. 

Color Burn  

This darkens the top layer increasing the contrast to reflect the color of the bottom 

layer. The darker the bottom layer, the more its color is used. Blending with white 

produces no difference. 

Color Dodge  

This decreases the contrast to make the bottom layer reflect the top layer: the brighter 

the top layer, the more its color affects the bottom layer. Blending with white gives 

white. Blending with black does not change the image. 

Color Darken  Darken takes the darkest value for each pixel from each layer. 

Color Difference  

Difference subtracts the top layer from the bottom layer or the other way round; to 

always get a positive value. Blending with black produces no change, as values for all 

colors is 0.  

Exclusion 

Exclusion blending mode works very much like Difference but the contrast is lower. 

When white is the blend color, the base image is inverted. When black is the blend color, 

there is no change. 



 

CL Studio Live 

CL Studio Live  Docs        Code Laboratories  -  Copyright 2010                                     Page 34  of 36     

 

Glow Works similar to Vivid Light with focus on light pixels.  

Hard Light  Hard Light combines Multiply and Screen blend modes.  

Hard Mix  
This blend mode combines Color Dodge and Color Burn. Dodge applies to values 

greater than 128 dodge and burn to values less than 128. 

Light en Lighten takes the lightest pixel from each layer. 

Linear Burn  

This darkens the top layer decreasing the brightness (not touching the contrast) to 

reflect the color of the bottom layer. The darker the bottom layer, the more its color is 

used. Blending with white produces no difference.   

Linear Dodge  

This increases the brightness (but does not change the contrast) to make the bottom 

layer reflect the top layer: the brighter the top layer, the more its color affects the 

bottom layer. Blending with white g ives white. 

Linear Light  
Linear Light works almost exactly like Vivid Light except that it lightens or darkens by 

increasing or decreasing brightness instead of contrast. 

Multiply  
Multiply blend mode multiplies the numbers for each pixel of the top layer  with the 

corresponding pixel for the bottom layer.  

Negation  This blend inverts both layers, divides them, and then the result is inverted again.  

Overlay  

Overlay combines Multiply and Screen blend modes. Light parts of the picture become 

lighter and dark parts become darker. An overlay with the same picture looks like an S-

curve. 

Pin Light  

Pin Light blending mode replaces colors depending on the brightness of the blend co l-

or. If the blend color is more than 50% brightness and the base color is darker than the 

blend color, then the base color is replaced with the blend color.  

 

Reflect  Similar to Linear Dodge with darker pixels take focus. 

Screen 
With Screen blend mode the values of the pixels in the two layers are inverted, 

multiplied, and then inverted  again. This is in some way the opposite of multiply. 

Soft Light  
This is a softer version of Overlay. Applying pure black or white does not result in pure 

black or white. 

Vivid Light  
Burns or dodges the colors by increasing or decreasing the contrast, depending on the 

blend color.  
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8.9 Licensing  Comparison  Reference 

Feature Trial  Lite  Live  Ult imate  

Audience  

Provides users a 

demonstration of 

core functionality. 

Researchers and 

hobbyist using web 

cameras. 

Creative 

professionals, live 

visual artists. 

Production and 

design houses. 

Modules  10 20 45+  60+ 

Cameras 2 4 8 Unlimited 

Media  2 4 8 Unlimited 

Displays 2 4 8 Unlimited 

Streams 0 1 2 Unlimited 

Rack Units  3 6 12 Unlimited 

Proxies 2 2 2 Unlimited 

Offline Mode  No Yes Yes Yes 

     

License Free 30 Day Personal Commercial  - 

Updates  No 6 Months 6 Months - 

Support  Community Commercial Commercial - 

Availability  10/10/10  10/10/10  10/10/10  2011 

 

 

To learn more about CL Studio products visit:  http://cod elaboratories.com/studio/  

 

 

http://codelaboratories.com/studio/
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9 Copyrights & Trademarks  

Trademarks referred to within the CL-Studio Live product and its documentation  is the property of 

their respective trademark holders. None of these trademarks holders are affiliated with Code 

Laboratories, Inc or our products.  The referrals to these trademarks do not in any way constitute 

trademark use. Nor does the use of these trademarks intend to explore the goodwill associated with 

these trademarks.  Intel, Adobe, Apple, Microsoft, Korg, Sony and any associated trademark are 

property of their respective owners.   

Updates:  CL Terms & Trademarks: http://codelaboratories.com/kb/Terms -&-Trademarks 

®  2006-2010 © Copyright Code Laboratori es Incorporated and its licensors - All Rights 

Reserved. Code Labs, the CL Logo, CL Studio, CL Studio Live and CL Eye are trademarks of 

Code Laboratories Incorporated in the United States and/or other countries. 

http://codelaboratories.com/kb/Terms-&-Trademarks
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